CloneOps

Outbound calls
Resolved·Partial outage

We have identified the issue and released a fix.

Thu, Aug 21, 2025, 10:20 PM
(2 months ago)
·
Affected components
Website
Agents
Updates

Resolved

We have identified the issue and released a fix.

Thu, Aug 21, 2025, 10:20 PM

Investigating

We are experiencing an issue with outbound calling. Our team is investigating the root cause.

Thu, Aug 21, 2025, 08:26 PM(1 hour earlier)
Powered by